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1 Diffusion - Introduction générale

Imaginons que l’on dépose des gouttes de colorant dans un verre d’eau transparent
(Figure 1). Nous observons qu’au cours du temps le colorant tend à se répandre dans
l’eau jusqu’à produire un mélange homogène. Ce phénomène, appelé diffusion, cor-
respond à la tendance naturelle des particules à se répartir uniformément dans tout le
volume disponible.

L’observation de ce phénomène a conduit Adolf Fick à formuler une loi phénoménologique,
par analogie avec l’équation de la chaleur de Fourier. La loi de Fick stipule que les
particules se déplacent des zones de concentration élevée vers les zones de concentra-
tion plus faible et propose le courant de particules j⃗ est proportionnel au gradient de
concentration C. Dans un cas 1D, on écrit :

jx = −D
∂C

∂x
(1)

où D est le coefficient de diffusion. Associé au principe de conservation de la masse
(divj⃗ = −∂C

∂t ), on obtient l’équation de diffusion (ici à 1D)

∂C

∂t
= D

∂2C

∂x2
(2)

Au niveau microscopique, ce comportement correspond à un mouvement erratique d’un
grand nombre de particules du soluté dans le solvant (Figure 2). Les particules du so-
luté, en entrant en collision avec celles du solvant, se dispersent progressivement. C’est
ainsi que la concentration du soluté diminue localement dans les zones initialement
concentrées, tout en s’étendant de manière de plus en plus homogène dans l’ensemble
du volume disponible.

L’objectif de cette séance de Travaux Pratiques est d’établir un lien entre l’échelle
microscopique et l’échelle macroscopique pour décrire le phénomène de diffusion. A
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Figure 1 – Diffusion d’un colorant violet dans l’eau. Au départ, le colorant est
concentré en un seul endroit. Petit à petit, il se répand dans l’eau jusqu’à ce que
tout le mélange devienne uniforme.

Figure 2 – Initialement, le soluté (représenté par les particules bleues) est séparé
du solvant (représenté par les particules rouges) par une membrane imperméable.
Lorsqu’on retire cette membrane, les particules du soluté commencent à se diffuser
dans le solvant. Au fil du temps, leur répartition devient de plus en plus uniforme,
jusqu’à ce que la concentration devienne homogène dans l’ensemble du volume.
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l’échelle microscopique, le nombre extrêmement élevé de molécules (∼ NA ≈ 6.1023)
empêche d’adopter une description déterministe, newtonienne, pour chacune des molécules.
Il est cependant possible de recourir à une description probabiliste de la position des
particules, par exemple avec un modèle de marche aléatoire. Il s’agit de considérer que
chaque molécule, indépendante des autres, est un marcheur qui effectue à chaque pas
de temps τ un saut de taille typique l dans une direction aléatoire. On peut montrer
que si les sauts sont indépendants les uns des autres, sans mémoire (on appelle ça un
processus Markovien), la variance de la position

〈
x2

〉
croit linéairement avec le nombre

de pas N (voir Annexe A ou lecture avant TP). En passant à la limite continue en
temps (N = t/τ), on obtient, à 1D 〈

x2
〉
= 2Dt (3)

Avec D = l2/τ . Cette loi est mesurable à l’échelle macroscopique, via le profil de
concentration. La loi de diffusion apparâıt ainsi comme une propriété statistique du
mouvement brownien.

Reste à savoir comment ce coefficient de diffusion dépend des propriétés géométriques
et thermodynamiques des molécules et du solvant. Albert Einstein a établi une relation
de fluctuation-dissipation reliant la diffusion et le frottement visqueux. Intuitivement,
la diffusion résulte des forces aléatoires exercées par les molécules du solvant, qui
déplacent en permanence les particules, et la viscosité s’oppose à ce mouvement et
tend à ralentir les particules. À l’équilibre thermique, Einstein obtient

Dγ = kT

où D est le coefficient de diffusion, γ est un coefficient de frottement, proportionnel à la
viscosité du solvant. Pour des particules sphériques de rayon R, on trouve γ = 6πηR,
avec kB la constante de Boltzmann et T la température du système. Cette relation
s’appelle la loi de Stokes-Einstein :

D =
kBT

6πηR
(4)

La séance de TP est constituée de deux parties. La première partie (Section 1.1),
consiste à mesurer le coefficient de diffusion D à l’échelle macroscopique, en exploitant
les variations de l’indice optique du mélange soluté-solvant en fonction de la concentra-
tion du soluté. Dans la seconde partie (Section 1.2), nous mesurerons les trajectoires
de microparticules collöıdales de polystyrène par observation directe au microscope.
Nous montrerons que ces particules ont un comportement brownien et nous extrairons
les coefficients de diffusion pour différentes tailles de particules. Nous testerons ainsi
la validité de la loi de Stokes-Einstein (Eq. 4).
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Lecture avant le TP

1. Annexe A : Éléments théoriques - Mouvement Brownien

2. Annexe B : Éléments théoriques - Expérience de Sommerfeld

Objectifs du TP

— Observer le mouvement brownien de particules microscopiques.

— Relier le mouvement brownien au phénomène de diffusion.

— Déterminer un coefficient de diffusion à partir de l’analyse des trajectoires
de particules.

— Vérifier expérimentalement la loi de Stokes–Einstein.

— Mettre en oeuvre l’expérience de Sommerfeld pour déterminer un coeffi-
cient de diffusion optiquement.

Objectifs pédagogiques

— Comprendre l’origine microscopique de la diffusion.

— Comprendre le lien entre diffusion, agitation thermique et mouvement
brownien.

— Se familiariser avec l’acquisition et le traitement d’images expérimentales.

— Apprendre à extraire et exploiter des trajectoires de particules.

— Manipuler des outils de programmation scientifique (Python, bi-
bliothèques).

— Mettre en œuvre une démarche de modélisation et de simulation
numérique.

— Confronter résultats théoriques, numériques et expérimentaux.

— Développer l’analyse critique et la présentation scientifique des résultats.

1.1 Diffusion – Expérience de Sommerfeld

L’expérience de Sommerfeld illustre le phénomène de diffusion moléculaire à l’échelle
macroscopique. Une cuve est remplie d’eau, puis un mélange eau–glycérol est intro-
duit en dessous, de manière à créer une interface quasi plane entre les deux liquides.
Le système est ainsi stratifié. Lorsque les deux liquides s’interpénètrent, la diffusion
engendre un gradient vertical de concentration. Comme l’indice de réfraction d’un
mélange eau/glycérol dépend de sa concentration, le gradient de concentration induit
donc un gradient d’indice de réfraction optique.
En pratique, on détermine ce gradient d’indice en mesurant la déflexion d’un faisceau
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laser élargi en nappe, qui traverse la cuve avec un angle d’environ 45° par rapport à
l’horizontale (voir figure 3). En présence du gradient d’indice, les rayons lumineux se
courbent vers les indices optiques les plus grands. La nappe laser est ainsi déformée, un
creux se produit sur une zone qui correspond à l’étendue du gradient de concentration
(Fig. 3). On peut montrer[3] que l’angle de déviation maximal αmax est proportionnel
à l’intensité du gradient et s’écrit :

αmax = d
ng − nw

cr

1

2
√
πDt

(5)

– d : épaisseur interne de la cuve
– ng, nw : indices de réfraction du glycérol pur et de l’eau
– cr est la concentration relative du mélange eau-glycérol
– D : coefficient de diffusion du glycérol dans l’eau

L’étude de la variation de αmax en fonction du temps permet ainsi de déduire une
valeur du coefficient de diffusion D.

Figure 3 – Déviation d’une feuille laser lors de l’expérience de Sommerfeld. Un fais-
ceau laser, élargi en nappe à l’aide d’une lentille cylindrique, traverse une cuve conte-
nant de l’eau et un mélange eau-glycérol sous un angle de 45◦. Le gradient d’indice de
réfraction induit par la diffusion courbe la trajectoire du faisceau (trace rouge observée
sur l’écran). À l’équilibre diffusif, la trajectoire redevient rectiligne (ligne pointillée
noire) [3].

1.1.1 Partie expérimentale

Matériel et montage optique
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Attention : le remplissage de la cuve doit être effectué uniquement lorsque
l’acquisition des images est prête à démarrer.

Le montage expérimental illustré sur la figure 3 est organisé de la manière suivante.
Un laser est d’abord élargi en nappe grâce à une lentille cylindrique, puis dirigé vers la
cuve. La position de chaque élément optique sur le banc est repérée par des traits de
référence gravés aux extrémités de son support. La distance entre la lentille et l’entrée
de la cuve est de 4 cm, ce qui permet de former une feuille laser suffisamment large
pour traverser toute la cuve. Le faisceau traverse la cuve avec un angle d’environ 45◦

par rapport à l’horizontale.

Après avoir traversé la cuve, le laser atteint l’écran placé à 20 cm de la cuve , où l’on
peut observer la déviation du faisceau induite par le gradient d’indice de réfraction.
Enfin, un appareil photo est positionné à 21 cm de l’écran pour capturer l’image du
faisceau.

Les distances indiquées constituent une première estimation et peuvent être modifiées
pour optimiser le montage. On notera précisément dans son cahier la distance entre
la cuve et l’écran. Avant de commencer les mesures, il est également important de
vérifier l’alignement du dispositif : le faisceau doit traverser la cuve correctement à 45°
et apparâıtre sur l’écran de manière nette.

Contrôle de la caméra et acquisition des images

Allumez l’appareil photo et connectez-le à l’ordinateur à l’aide du câble USB. Vérifiez
que la molette de sélection des modes est bien positionnée sur le mode manuel (M).
Lancez le logiciel (Imaging Edge Desktop) et sélectionnez l’appareil photo, l’aperçu de
l’image doit apparâıtre à l’écran.

Effectuez la mise au point manuellement à l’aide de la bague de mise au point et
vérifiez le cadrage et l’exposition à l’aide de l’aperçu à l’écran. Scotchez un morceau
de papier millimétré sur l’écran optique et prenez une photo. Cela servira de référence
pour le rapport pixels/centimètres. Ne changez plus les réglages ni la position
de la caméra.

Remplissez d’abord la cuve avec 20 mL d’eau distillée. À l’aide d’une seringue, ajoutez
ensuite très lentement 20 mL de solution de glycérol à cr=25% au fond de la cuve afin
de limiter au maximum toute convection. Le mélange eau-glycérol, plus dense, doit
rester en bas de la cuve, l’eau distillée au-dessus. Retirez très délicatement la pipette.

La prise de vue par intervalles est configurée depuis le panneau latéral droit du logi-
ciel : dans le panneau Shooting, sélectionnez l’icône horloge pour accéder aux réglages
d’intervalle et de nombre d’images. Réglez l’intervalle de prise de vue à toutes les 5
minutes pour 3 heures et lancez l’acquisition automatique. Vérifiez de temps en temps
que les images sont correctement prises.
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1.2 Diffusion - Mouvement brownien

Dans cette partie expérimentale, nous observerons le mouvement erratique de parti-
cules collöıdales de polystyrène dispersées dans l’eau, puis nous suivrons leurs tra-
jectoires pour calculer leur déplacement quadratique moyen (MSD) et en déduire le
coefficient de diffusion D. Nous répéterons cette procédure pour des particules de
rayons différents (R = {0.5 µm, 0.75µm, 1.0 µm}), afin de vérifier la validité de la loi
de Stokes-Einstein (Éq. 4).

1.2.1 Préparation du dispositif expérimental

Pour préparer la solution collöıdale on dispose d’une solution stock, dont la fraction
volumique de particules est ϕ0 = 0.026%. Vortexez bien le tube de la solution stock,
effectuez une dilution à l’aide d’une micropipette pour obtenir 100µL à une fraction
volumique finale de ϕf = 0.0026%.

Vortexez le tube de la dilution et prélevez 60 µL de la solution diluée à l’aide d’une
micropipette, et déposez la dans une lame de microscope à cavité. Couvrez la lame
avec une lamelle et scellez les bords en utilisant la cire.

Positionnez la lame de verre sur la platine du microscope inversé, avec la lamelle face
à l’objectif. Avec la roue à objectif, choisissez successivement des grandissement crois-
sant, de 10x jusqu’à 40x et réglez chaque fois la mise au point et le temps d’exposition.
Assurez vous de ne pas observer de dérive (c’est à dire un mouvement directionnel des
particules, du à une mauvais étanchéité par exemple).

Prenez une séquence temporelle d’image d’une minute, avec des prise d’image toutes
les 100ms. Sauvegardez les images au format TIFF et transferez-les sur une clé USB.

Répétez ces manipulations pour les trois tailles de particules disponibles.

Prenez une photo d’étalonnage avec une règle micrométrique

1.3 Diffusion - Analyse des données et simulations

1.3.1 Analyses de données - Sommerfeld

Traitement des images sous Fiji Fiji est un logiciel de traitement d’images, lar-
gement utilisé en sciences expérimentales. Il permet de mesurer, analyser et visualiser
des données à partir d’images numériques.

— Ouvrir Fiji et charger l’image de calibration contenant la le papier millimétré
visible sur l’écran d’observation (File → Open).

— À l’aide de l’outil ligne droite, tracer un segment correspondant à une lon-
gueur connue, puis sélectionner Analyze → Measure afin d’obtenir la longueur
correspondante en pixels.
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— Définir le rapport pixel-mètre en utilisant la commande Analyze → Set Scale. . .,
en renseignant la distance mesurée en pixels, la distance réelle correspondante et
l’unité associée. Cochez la case global. Notez le rapport.

— Charger ensuite la séquence des images expérimentales (File → Import → Image
Sequence). Sélectionner une région d’intérêt grâce à l’outil rectangle corres-
pondant à la zone où apparâıt le laser, puis appliquer cette sélection à l’ensemble
de la pile à l’aide de Image → Crop.

— Convertir la pile d’images en niveaux de gris (Image → Type → 8-bit).

— Un filtre médian est appliqué à l’ensemble de la pile afin de supprimer les pixels
aberrants tout en conservant les contours de la feuille laser. Le filtre est appliqué
via Process → Filters → Median..., avec un rayon typique de 1 à 2 pixels et
l’option Process Stack activée.

— Un flou gaussien est appliqué à l’ensemble de la pile afin de réduire le bruit
de fond. Le filtre est appliqué via le menu Process → Filters → Gaussian

Blur, avec une largeur typique σ = 1 pixels et l’option Process Stack activée.

— Le contraste local des images est ensuite amélioré à l’aide de la méthode CLAHE
(Contrast Limited Adaptive Histogram Equalization).

Dans certaines versions de Fiji, le plugin Enhance Local Contrast ne traite
qu’une seule image du stack ; il est alors nécessaire de l’appliquer à l’ensemble
des slices via une macro. Créer et exécuter une macro (Plugins → New → Macro)
afin d’appliquer CLAHE à toute la pile d’images :

n = nSlices();

for (i = 1; i <= n; i++) {

setSlice(i);

run("Enhance Local Contrast (CLAHE)",

"blocksize=63 histogram=256 maximum=3 mask=*None*");

}

— Afin de corriger les variations d’illumination et supprimer le fond lentement
variable, on applique ensuite une soustraction de fond (Sliding Paraboloid) via
Process → Subtract Background.... Un rayon typique est choisi de l’ordre
de la taille des structures à éliminer (par exemple 50 à 500 pixels selon l’image),
avec l’option Process Stack activée.

— Appliquer un seuillage (threshold) afin de segmenter la feuille laser par rap-
port au fond. Ouvrir Image → Adjust → Threshold. . ., ajuster les curseurs si
nécessaire, puis cliquer sur Apply. Si une fenêtre s’ouvre en proposant de re-
calculer automatiquement le seuil pour chaque image de la pile, décocher cette
option afin d’appliquer le même seuil à toutes les images. Vérifier que la feuille
laser apparâıt en blanc sur fond noir.

— Appliquer une squelettisation de l’image binaire afin de réduire la feuille laser
à une ligne d’un pixel d’épaisseur, via Process → Binary → Skeletonize.

— Extraire les coordonnées des pixels du squelette pour l’ensemble du
stack. Les commandes Create Selection et Save XY Coordinates ne s’appliquant
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qu’à une image à la fois, on utilise une macro Fiji qui parcourt automatiquement
les 30 slices et exporte, pour chaque image, les coordonnées des pixels blancs
dans un fichier CSV au format slice,x,y. La macro est créée via Plugins → New
→ Macro, puis exécutée :

dir = getDirectory("Dossier de sortie");

out = dir + "skeleton_pixels.csv";

File.saveString("slice,x,y\n", out);

n = nSlices(); w = getWidth(); h = getHeight();

setBatchMode(true);

for (s=1; s<=n; s++) {

setSlice(s);

for (y=0; y<h; y++) for (x=0; x<w; x++)

if (getPixel(x,y)>0) File.append(s+","+x+","+y+"\n", out);

}

setBatchMode(false);

print("OK: " + out);

Analyse des images sur Jupyter

L’analyse des images est réalisée à l’aide d’un notebook Jupyter à récupérer par clé
USB sur l’ordinateur de Travaux Pratique. Pour chaque image, on mesure la profondeur
maximale h du creux de la feuille laser (voir Fig. 6. Les valeurs de h en fonction du
temps seront ensuite regroupées afin d’étudier leur évolution temporelle.
- Tracer α en fonction du temps, en échelle log-log. Le comportement est-il diffusif
comme attendu ?
- Ajuster ces données, pour déterminer le coefficient de diffusion D en s’appuyant sur
l’équation 5 liant αmax au temps.
- Si on admet que la relation de Stokes-Einstein est vérifiée pour les molécules de
glycérol, quelle est la taille typique de la molécule ? Commenter votre résultat.

1.3.2 Analyses des données - Mouvement Brownien

Pour l’analyse des images on utilisera les librairies NumPyn Matplotlib, OpenCV,
TrackPy et Pandas, respectivement pour le traitement d’images, pour obtenir les tra-
jectoires des particules et enfin pour traiter/ajuster les données et extraire les coeffi-
cients de diffusion.
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Traitement des images

Afin de suivre les trajectoires des particules, il faut d’abord les trouver. Pour cela,
nous utilisons une série de méthodes qui nous permettent de mieux les isoler du fond
de l’image.
Ouvrir et consulter la documentation relative à OpenCV.
À l’aide d’OpenCV, chargez les images, appliquez un filtre gaussien pour optimiser
la détection, puis utilisez findContours et contourArea pour identifier les particules
et ne sélectionner que celles dont la taille est adaptée. Calculez leurs centröıdes avec
moments, puis enregistrez les coordonnées (x, y) et le numéro de chaque image dans
un DataFrame pour analyse ultérieure.

Suivi des particules

Une fois les centroides de chaque particules obtenus pour chaque image, il s’agit
désormais de suivre les trajectoires de chaque particules. Pour ce faire on utilise un
programme de tracking (“suivi de particules”), c’est à dire une fonction qui associe la
position d’une particule donnée dans une image à sa position à l’image suivante.
Ouvrir et consulter la documentation relative à TrackPy.
Utilisez la méthode link en ajustant les paramètres search range et memory pour
relier les particules détectées précédemment. Enfin, visualisez les trajectoires obtenues
avec plot traj.

Calcul du MSD

Pour mesurer le coefficient de diffusion, nous allons désormais déterminer le déplacement
quadratique moyen des particules en fonction du temps. Comme les particules sont sup-
posées indépendantes (à faible concentration) on peut augmenter le rapport signal sur
bruit en effectuant une moyenne d’ensemble sur les Np différents marcheurs

〈
x⃗(t)2

〉
=

1

Np

N∑
i=1

p(x⃗(t)− x⃗(0))2. (6)

Si par ailleurs on fait l’hypothèse que le système est ergodique (moyenne d’ensemble
et temporelle sont identiques), on peut calculer le déplacement quadratique moyen par
rapport à des intervalles de temps ∆t, et non pas un temps absolu. Grace à cela, on
augmente considérablement le nombre d’échantillons et obtient des résultats statisti-
quement plus significatifs. Cela revient à moyenner sur le temps et sur les différentes
particules,

〈
∆x⃗(∆t)2

〉
=

〈
(x⃗(t+∆t)− x⃗(t))2

〉
(t,Np)

. En pratique :

〈
∆x⃗(∆t)2

〉
=

1

Np

Np∑
i=1

1

M − k

M−k−1∑
j=1

[(x0
i,j+k − x0

i,j)
2 + (x1

i,j+k − x1
i,j)

2] (7)
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dans le cas bidimensionnel.

Ecrire un code Python qui extrait
〈
x(t)2

〉
en utilisant ces deux approches (moyenne

sur les particules et/ou sur le temps) et tracez-les en fonction du temps, ou de ∆t,
respectivement. Laquelle Vous semble-t-elle la meilleure ?
Ajuster linéairement ces données, et calculezD pour rayonsR = {0.5µm, 0.75 µm, 1.0 µm}.
Est la loi de Stokes-Einstein vérifiée ?

1.3.3 Simulation du Mouvement Brownien

Dans cette partie, nous allons simuler des marcheurs aléatoires en deux dimensions afin
de tester le modèle de mouvement brownien. Pour cela, nous générons des déplacements
en x et en y en tirant aléatoirement ces valeurs dans une distribution gaussienne.
Nous vérifierons que ces trajectoires possèdent bien les propriétés caractéristiques des
particules browniennes, notamment leur comportement diffusif.

Plusieurs marcheurs aléatoires en 2D

Vous pouvez utiliser l’option size de la méthode NumPy np.random.normal pour
créer plusieurs marcheurs aléatoires. Générer les déplacements (à 2D) et déterminer
les positions pour 10 marcheurs. Utiliser une fonction Matplotlib pour visualiser les
trajectoires des marcheurs en 2D en différents couleurs

1.3.4 Écart quadratique moyen en fonction du temps

Calculer le déplacement quadratique moyen selon les deux méthodes présentées plus
haut. Simulez 100 marcheurs aléatoires avec 600 pas chacun. Calculez l’écart quadra-
tique moyen (MSD) à partir des trajectoires simulées en utilisant d’abord l’équation 6,
puis l’équation 7, et comparez les résultats. Enfin, effectuez une régression linéaire sur
la première moitié des pas pour les deux méthodes et évaluez la qualité de l’ajustement
avec le coefficient R2.

Loi de Stokes-Einstein

On peut calculer avec cette formule le coefficient de diffusion D qui on peut s’attendre
dans l’eau (coefficient de viscosité η = 1 × 10−3 Pa s) à température ambiance (T =
25 ◦C) pour des particules avec un certain rayon R. Trouvez les coefficients de diffusion
pour des particules de rayon 0.23µm, 0.39µm, 0.49 µm, 1.0 µm, 1.49 µm Utilisez les
valeurs de D que vous avez trouvé pour redimensionner les marches aléatoires. Prenez
des intervalles de temps de 100ms.
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On the Wiener optical method to study molecular diffusion in liquids, Am. J. Phys.
88(8), 661–669 (2020).

[4] A. Sommerfeld, Optics, Lectures on Theoretical Physics, Vol. IV, Academic Press,
Cambridge (1954).

[5] P.G. De Gennes, F. Brochard-Wyart, David Quéré Gouttes, Bulles, Perles et
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A Éléments théoriques - Mouvement Brownien

Pour mieux comprendre le lien entre échelle microscopique et macroscopique prenons
l’exemple d’un marcheur aléatoire à 1D pour retrouver l’équation de diffusion.

Figure 4 – Marcheur aléatoire sur grille en 1D.

On considère une marche aléatoire à une dimension. Le marcheur part de la position
x = 0, et à chaque pas i il fait un saut à gauche ou à droite d’une distance ℓ avec
probabilité 1/2. Le déplacement δxi s’écrit donc :

δxi =

{
+ℓ, p+ = 1

2

−ℓ, p− = 1
2

Par construction, la moyenne des déplacements est ⟨δxi⟩ = 0 et la variance est
〈
δx2

i

〉
=

ℓ2.
La position absolue du marcheur après N pas s’exprime comme la somme de tous les
déplacements successifs :

xN =

N∑
i=0

δxi.

On obtient donc immédiatement pour la position moyenne :

⟨xN ⟩ =
∑
i

⟨δxi⟩ = 0
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D’autre part, les déplacements étant indépendants, la variance de leur somme est égale
à la somme de leur variance. Il vient :〈

x2
N

〉
=

∑
i

〈
δx2

i

〉
= Nℓ2.

En prenant le passage à la limite continue en temps N = t/τ , avec τ le temps typique
entre deux collisions, il vient : 〈

x(t)2
〉
= ℓ2t/τ = 2Dt

où on a défini D = ℓ2/2τ . Ce modèle simple fournit ainsi une définition microscopique
du coefficient de diffusion. Mais le processus est-il véritablement diffusif ? Pour s’en
convaincre, il faut déterminer la loi d’évolution de la concentration de marcheur. Or la
concentration de marcheur est proportionnelle à la probabilité de trouver un marcheur
en dans une région de l’espace après N pas.
La probabilité que le marcheur se trouve à une certaine position après N pas s’écrit

PN+1(x) =
1

2
PN (x− ℓ) +

1

2
PN (x+ ℓ) (8)

En passant à la limite continue

PN (x) → P (x, t) avect = Nτ (9)

en utilisant un développement de Taylor pour la position et le temps, on obtient

P (x± ℓ, t) = P (x, t)± ℓ
∂P (x, t)

∂x
+

1

2
ℓ2
∂2P (x, t)

∂x2
(10)

P (x, t± τ) = P (x, t)± τ
∂P (x, t)

∂x
(11)

En utilisant les définitions 10 et 11 dans l’équation 8 on obtient

P (x, t+ τ) =
1

2
[P (x− ℓ, t) + P (x+ ℓ, t)] (12)

P + ∂tP =
1

2

[
P + ℓ∂xP +

1

2
ℓ2∂2

xP − ℓ∂xP +
1

2
ℓ2∂2

xP

]
(13)

= P +
1

2
ℓ2∂2

xP (14)

où P ≡ P (x, t). L’équation précédente se réécrit comme

∂P (x, t)

∂t
=

ℓ2

2τ

∂2P (x, t)

∂x2
= D

∂2P (x, t)

∂x2
(15)

On retrouve bien une équation de diffusion pour la probabilité, et donc pour la concen-
tratio de particules.
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Figure 5 – Les trajectoires des marcheurs sont représentées en semi-transparence pour
mieux visualiser les chevauchements. On observe que la distribution des positions suit
une loi gaussienne. De plus, on remarque que la variance de cette distribution augmente
avec le temps, conformément aux prédictions théoriques.

En prenant pour condition initiale P (x, 0) = δ(x), on peut montrer que la la solution
de l’équation de diffusion est une Gaussienne

P (x, t) =
1√
4πDt

e−
x2

4Dt (16)

avec une variance qui croit linéairement dans le temps〈
x2(t)

〉
= 2Dt. (17)

B Elements théoriques - Sommerfeld

B.1 Diffusion du glycérol et variation de l’indice optique

On considère que la concentration molaire du glycérol c (mol·m−3) dans la cuve obéit
à la seconde loi de Fick lors de l’interdiffusion :

∂c

∂t
=

∂

∂z

[
D(c)

∂c

∂z

]
, c = c(z, t). (18)

En évitant la convection, les effets liés à la différence de densité entre l’eau et le mélange
eau-glycérol sont négligés. Les conditions initiales de concentration sont :

c(z, t = 0) =

{
0 z < 0,

c0 z > 0,
(19)
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où c0 est la concentration de glycérol correspondant à un mélange eau–glycérol à 25 %.
La concentration molaire du glycérol pur est cg = 1.37× 103 molm−3

Pour une cuve d’épaisseur de 3 cm et pour des temps courts, l’approximation du milieu
infini est suffisante pour décrire l’évolution du profil de concentration. La solution
analytique de l’équation de diffusion s’écrit alors :

c(z, t) =
c0
2

[
1 +

2√
π

∫ z
2
√

Dt

0

exp
(
−u2

)
du

]
. (20)

L’indice de réfraction n du mélange varie linéairement avec la concentration en glycérol :

n(c) = nw +
c

cglycérol
(ng − nw), (21)

avec nw = 1.333 l’indice de l’eau et ng = 1.473 celui du glycérol pur.

On peut ainsi déduire la variation de l’indice de réfraction en fonction de la position
z et relier cela au gradient de concentration :

∂n

∂z
=

ng − nw

cg

∂c

∂z
=

ng − nw

cg

c0

2
√
πDt

exp

(
− z2

4Dt

)
. (22)

B.2 Déviation d’un rayon lumineux dans un milieu à indice
variable

La propagation d’un rayon lumineux dans un milieu à indice variable est décrite par
l’équation éikonale en optique géométrique :

|∇S(r)| = n(r), (23)

où S(r) est la phase optique.

La direction locale du rayon est définie par le vecteur unitaire :

s =
∇S

n
. (24)

La courbure du rayon est donnée par :

K =
ds

ds
. (25)

On montre alors que :
nK = ∇n− s(s · ∇n). (26)
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Dans notre cas, le gradient d’indice est perpendiculaire à la direction de propagation
du rayon. La courbure s’écrit donc :

K =
1

n

∂n

∂z
. (27)

La trajectoire du rayon à travers la cuve est approximée par un arc de cercle de rayon
R, avec K = 1/R :

1

R
=

1

n

∂n

∂z
. (28)

Figure 6 – Trajectoire d’un rayon lumineux dans la cuve en présence d’un gradient
d’indice. [3]

En supposant que le gradient d’indice varie peu sur l’épaisseur de la cuve, la déviation
angulaire θ vérifie :

sin θ ≃ d

R
(29)

où d est l’épaisseur de la cuve.

En utilisant la loi de Snell-Descartes à la sortie de la cuve, on obtient pour l’angle de
déviation :

α ≃ d
∂n

∂z
(30)

αmax(t) =
d (ng − nw)

2
√
πD t

c0
cg

. (31)

La mesure de l’angle de déviation maximal en fonction du temps permet ainsi de
déterminer le coefficient de diffusion D, via l’évolution de αmax en fonction de 1/

√
t.
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